summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-05-06 21:34:49 +0200
committerAndreas Enge <andreas@enge.fr>2015-05-06 21:34:49 +0200
commit9fe8a4ba4e6c13aba810bf03015e466518417c45 (patch)
treeb6353bb89dafcce6af7fe1d036d10f43f0ba301e /gnu
parent4cd369ed6b0c095d9bb9a5550e84eba22630677d (diff)
downloadpatches-9fe8a4ba4e6c13aba810bf03015e466518417c45.tar
patches-9fe8a4ba4e6c13aba810bf03015e466518417c45.tar.gz
gnu: Add libcdr.
* gnu/packages/libreoffice.scm (libcdr): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/libreoffice.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 1c5b195310..71bd94e8ad 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -26,6 +26,7 @@
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages doxygen)
+ #:use-module (gnu packages ghostscript)
#:use-module (gnu packages gperf)
#:use-module (gnu packages icu4c)
#:use-module (gnu packages perl)
@@ -229,3 +230,33 @@ working with graphics in the WPG (WordPerfect Graphics) format.")
(description "Libabw is a library that parses the file format of
AbiWord documents.")
(license mpl2.0)))
+
+(define-public libcdr
+ (package
+ (name "libcdr")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://dev-www.libreoffice.org/src/" name "/"
+ name "-" version ".tar.xz"))
+ (sha256 (base32
+ "07yzb1yr5kzv0binzj5swz3zzay2gw3xb0fbkc2zwdssgrkf19nh"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("doxygen" ,doxygen)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("boost" ,boost)
+ ("icu4c" ,icu4c)
+ ("lcms" ,lcms)
+ ("librevenge" ,librevenge)
+ ("zlib" ,zlib)))
+ (arguments
+ ;; avoid triggering a build failure due to warnings
+ `(#:configure-flags '("--disable-werror")))
+ (home-page "https://wiki.documentfoundation.org/DLP/Libraries/libcdr")
+ (synopsis "Library for parsing the CorelDRAW format")
+ (description "Libcdr is a library that parses the file format of
+CorelDRAW documents of all versions.")
+ (license mpl2.0)))