summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-05-06 21:47:45 +0200
committerAndreas Enge <andreas@enge.fr>2015-05-06 21:51:52 +0200
commit97aee2b6a57a66608ee9eee919933f2e4900886e (patch)
treef03fa06355003befdc96db464a17ea9106d34f6a /gnu
parent3dc67e38946b2784b2162335e9de1afd17d0d21e (diff)
downloadpatches-97aee2b6a57a66608ee9eee919933f2e4900886e.tar
patches-97aee2b6a57a66608ee9eee919933f2e4900886e.tar.gz
gnu: Add libexttextcat.
* gnu/packages/libreoffice.scm (libexttextcat): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/libreoffice.scm21
1 files changed, 20 insertions, 1 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 3e5f331fdb..4df809528c 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -20,7 +20,7 @@
(define-module (gnu packages libreoffice)
#:use-module (guix packages)
#:use-module (guix download)
- #:use-module ((guix licenses) #:select (lgpl2.1+ mpl2.0))
+ #:use-module ((guix licenses) #:select (lgpl2.1+ mpl2.0 non-copyleft))
#:use-module (guix build-system gnu)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
@@ -287,3 +287,22 @@ CorelDRAW documents of all versions.")
(description "Libetonyek is a library that parses the file format of
Apple Keynote documents. It currently supports Keynote versions 2 to 5.")
(license mpl2.0)))
+
+(define-public libexttextcat
+ (package
+ (name "libexttextcat")
+ (version "3.4.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://dev-www.libreoffice.org/src/" name "/"
+ name "-" version ".tar.xz"))
+ (sha256 (base32
+ "14v2hkygnmf1zgahfm1fha47cr67iikrz2ymiqi28d2jydn0hk7j"))))
+ (build-system gnu-build-system)
+ (home-page "http://www.freedesktop.org/wiki/Software/libexttextcat/")
+ (synopsis "Text Categorization library")
+ (description "Libexttextcat is an N-Gram-Based Text Categorization
+library primarily intended for language guessing.")
+ (license (non-copyleft "file://LICENSE"
+ "See LICENSE in the distribution."))))