summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2015-06-27 00:18:55 +0200
committerCyril Roelandt <tipecaml@gmail.com>2015-06-30 00:07:56 +0200
commite8df8f476e4a87b41278e2d358be612286fa6a6f (patch)
tree76e2735437cae3a51ba5e85f598198c8072543d9 /gnu
parenta59e017cb14ac4b30b46fbd7f2a76b29004d25f4 (diff)
downloadpatches-e8df8f476e4a87b41278e2d358be612286fa6a6f.tar
patches-e8df8f476e4a87b41278e2d358be612286fa6a6f.tar.gz
gnu: Add python-flake8.
* gnu/packages/python.scm (python-flake8, python2-flake8): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm70
1 files changed, 70 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index fd3fedec27..c62184b510 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3980,3 +3980,73 @@ complexity of Python source code.")
(define-public python2-mccabe
(package-with-python2 python-mccabe))
+
+;; Flake8 2.4.1 requires an older version of pep8.
+;; This should be removed ASAP.
+(define-public python-pep8-1.5.7
+ (package (inherit python-pep8)
+ (version "1.5.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/p/pep8/pep8-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "12b9bbdbwnspxgak14xg58c130x2n0blxzlms5jn2dszn8qj3d0m"))))))
+
+(define-public python2-pep8-1.5.7
+ (package-with-python2 python-pep8-1.5.7))
+
+;; Flake8 2.4.1 requires an older version of pyflakes.
+;; This should be removed ASAP.
+(define-public python-pyflakes-0.8.1
+ (package (inherit python-pyflakes)
+ (version "0.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/p/pyflakes/pyflakes-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0sbpq6pqm1i9wqi41mlfrsc5rk92jv4mskvlyxmnhlbdnc80ma1z"))))))
+
+(define-public python2-pyflakes-0.8.1
+ (package-with-python2 python-pyflakes))
+
+(define-public python-flake8
+ (package
+ (name "python-flake8")
+ (version "2.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/f/flake8/flake8-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0dvmrpv7x98xkzffjz1z7lqr90sp5zdz16bdwckfd1cckpjvnzif"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)
+ ("python-pep8" ,python-pep8-1.5.7)
+ ("python-pyflakes" ,python-pyflakes-0.8.1)
+ ("python-mccabe" ,python-mccabe)
+ ("python-mock" ,python-mock)
+ ("python-nose" ,python-nose)))
+ (home-page "https://gitlab.com/pycqa/flake8")
+ (synopsis
+ "The modular source code checker: pep8, pyflakes and co")
+ (description
+ "Flake8 is a wrapper around PyFlakes, pep8 and python-mccabe.")
+ (license license:expat)))
+
+(define-public python2-flake8
+ (package-with-python2 python-flake8))