summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-01-21 11:41:10 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-01-21 15:53:35 +0100
commitbd0eb6672b0444359818e8e0a1a9f15690802636 (patch)
tree45fa9ab52d8c880927b57477ee349e2f9b5e5a7d /gnu
parentb2844d8f14bbc2e57768b0c2868020da2faa5b0a (diff)
downloadpatches-bd0eb6672b0444359818e8e0a1a9f15690802636.tar
patches-bd0eb6672b0444359818e8e0a1a9f15690802636.tar.gz
gnu: bind-utils: Generalize "build" and "install" phases.
* gnu/packages/dns.scm (bind-utils)[arguments]: Generalize "build" and "install" phases.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/dns.scm28
1 files changed, 17 insertions, 11 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index f7d6c88ee4..dfdd1dfccc 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -91,18 +91,24 @@ and BOOTP/TFTP for network booting of diskless machines.")
(assoc-ref %build-inputs "mysql"))
(string-append "--with-pkcs11="
(assoc-ref %build-inputs "p11-kit")))
+ #:modules ((srfi srfi-1)
+ (srfi srfi-26)
+ ,@%gnu-build-system-modules)
#:phases
- (modify-phases %standard-phases
- (replace 'build
- (lambda _
- (and (zero? (system* "make" "-C" "lib/dns"))
- (zero? (system* "make" "-C" "lib/isc"))
- (zero? (system* "make" "-C" "lib/bind9"))
- (zero? (system* "make" "-C" "lib/isccfg"))
- (zero? (system* "make" "-C" "lib/lwres"))
- (zero? (system* "make" "-C" "bin/dig")))))
- (replace 'install
- (lambda _ (zero? (system* "make" "-C" "bin/dig" "install")))))))
+ (let ((libs '("dns" "isc" "bind9" "isccfg" "lwres"))
+ (bins '("dig")))
+ (modify-phases %standard-phases
+ (replace 'build
+ (lambda _
+ (every (lambda (dir)
+ (zero? (system* "make" "-C" dir)))
+ (append (map (cut string-append "lib/" <>) libs)
+ (map (cut string-append "bin/" <>) bins)))))
+ (replace 'install
+ (lambda _
+ (every (lambda (dir)
+ (zero? (system* "make" "-C" dir "install")))
+ (map (cut string-append "bin/" <>) bins))))))))
(home-page "https://www.isc.org/downloads/bind/")
(synopsis "Tools for querying nameservers")
(description