summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2015-12-29 14:42:53 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-01-26 16:15:24 +1000
commit78bb471f37dbe6d77bb258c5859861da7038f720 (patch)
tree29880b4ba15e048a1aedb47b8ad0ceaa02aab96f /gnu
parent9273ee8f448ae075b4df62b9ad793c1dcf31b7be (diff)
downloadpatches-78bb471f37dbe6d77bb258c5859861da7038f720.tar
patches-78bb471f37dbe6d77bb258c5859861da7038f720.tar.gz
gnu: Add ruby-lemon.
* gnu/packages/ruby.scm (ruby-lemon): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 5cbf125ded..c159e53c9f 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3118,3 +3118,33 @@ requirement specifications systems like Cucumber.")
for reuse by other test frameworks.")
(home-page "http://rubyworks.github.io/ae")
(license license:bsd-2)))
+
+(define-public ruby-lemon
+ (package
+ (name "ruby-lemon")
+ (version "0.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "lemon" version))
+ (sha256
+ (base32
+ "0gqhpgjavgpvx23rqpfqcv3d5bs8gc7lr9yvj8kxgp7mfbdc2jcm"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check (lambda _ (zero? (system* "qed")))))))
+ (propagated-inputs
+ `(("ruby-ae" ,ruby-ae)
+ ("ruby-ansi" ,ruby-ansi)
+ ("ruby-rubytest" ,ruby-rubytest)))
+ (native-inputs
+ `(("ruby-qed" ,ruby-qed)))
+ (synopsis "Test framework correlating code structure and test unit")
+ (description
+ "Lemon is a unit testing framework that enforces highly formal
+case-to-class and unit-to-method test construction. This enforcement can help
+focus concern on individual units of behavior.")
+ (home-page "http://rubyworks.github.io/lemon")
+ (license license:bsd-2)))