summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2013-09-04 19:21:38 +0200
committerCyril Roelandt <tipecaml@gmail.com>2013-09-06 20:59:55 +0200
commit20a26ff546a5b200785f84eb361d1db271edd0f4 (patch)
tree80d0ecb98afcc69132ce85bea4c246675b925a39 /gnu
parent785859d306eaffcb3488f2d23e4d6c9e4f5db3a5 (diff)
downloadpatches-20a26ff546a5b200785f84eb361d1db271edd0f4.tar
patches-20a26ff546a5b200785f84eb361d1db271edd0f4.tar.gz
gnu: Add itstool.
* gnu/packages/glib.scm (itstool): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/glib.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 63751bb510..c95ecb5672 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -186,6 +186,40 @@ The intltool collection can be used to do these things:
oaf files. This merge step will happen at build resp. installation time.")
(license license:gpl2+)))
+(define-public itstool
+ (package
+ (name "itstool")
+ (version "1.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://files.itstool.org/itstool/itstool-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "1akq75aflihm3y7js8biy7b5mw2g11vl8yq90gydnwlwp0zxdzj6"))))
+ (build-system gnu-build-system)
+ (home-page "http://www.itstool.org")
+ (synopsis "Tool to translate XML documents with PO files")
+ (description
+ "ITS Tool allows you to translate your XML documents with PO files, using
+rules from the W3C Internationalization Tag Set (ITS) to determine what to
+translate and how to separate it into PO file messages.
+
+PO files are the standard translation format for GNU and other Unix-like
+systems. They present translatable information as discrete messages, allowing
+each message to be translated independently. In contrast to whole-page
+translation, translating with a message-based format like PO means you can
+easily track changes to the source document down to the paragraph. When new
+strings are added or existing strings are modified, you only need to update the
+corresponding messages.
+
+ITS Tool is designed to make XML documents translatable through PO files by
+applying standard ITS rules, as well as extension rules specific to ITS Tool.
+ITS also provides an industry standard way for authors to override translation
+information in their documents, such as whether a particular element should be
+translated.")
+ (license gpl3+)))
+
(define-public dbus-glib
(package
(name "dbus-glib")