summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-09-01 23:13:00 +0200
committerLudovic Courtès <ludo@gnu.org>2013-09-02 00:20:14 +0200
commit1e151896d4fbd552a2e8dd66b16b7f746e0f6113 (patch)
tree9f77b2a109d1ebdf8c0e0cfd4b267942a625796d /gnu
parentbf8e7fc502057c5e59f541351a2bf35d2b20e612 (diff)
downloadpatches-1e151896d4fbd552a2e8dd66b16b7f746e0f6113.tar
patches-1e151896d4fbd552a2e8dd66b16b7f746e0f6113.tar.gz
gnu: Add mingetty.
* gnu/packages/system.scm (mingetty): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/system.scm50
1 files changed, 50 insertions, 0 deletions
diff --git a/gnu/packages/system.scm b/gnu/packages/system.scm
index e326e498c5..47a57c54cc 100644
--- a/gnu/packages/system.scm
+++ b/gnu/packages/system.scm
@@ -141,3 +141,53 @@ login, passwd, su, groupadd, and useradd.")
;; The `vipw' program is GPLv2+.
;; libmisc/salt.c is public domain.
(license bsd-3)))
+
+(define-public mingetty
+ (package
+ (name "mingetty")
+ (version "1.08")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/mingetty/mingetty-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "05yxrp44ky2kg6qknk1ih0kvwkgbn9fbz77r3vci7agslh5wjm8g"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases (alist-replace 'configure
+ (lambda* (#:key inputs outputs
+ #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (man8 (string-append
+ out "/share/man/man8"))
+ (sbin (string-append out "/sbin"))
+ (shadow (assoc-ref inputs "shadow"))
+ (login (string-append shadow
+ "/bin/login")))
+ (substitute* "Makefile"
+ (("^SBINDIR.*")
+ (string-append "SBINDIR = " out
+ "/sbin\n"))
+ (("^MANDIR.*")
+ (string-append "MANDIR = " out
+ "/share/man/man8\n")))
+
+ ;; Pick the right 'login' by default.
+ (substitute* "mingetty.c"
+ (("\"/bin/login\"")
+ (string-append "\"" login "\"")))
+
+ (mkdir-p sbin)
+ (mkdir-p man8)))
+ %standard-phases)
+ #:tests? #f)) ; no tests
+ (inputs `(("shadow" ,shadow)))
+
+ (home-page "http://sourceforge.net/projects/mingetty")
+ (synopsis "Getty for the text console")
+ (description
+ "Small console getty that is started on the Linux text console,
+asks for a login name and then transfers over to 'login'. It is extended to
+allow automatic login and starting any app.")
+ (license gpl2+)))