summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2018-03-24 21:37:41 -0400
committerArun Isaac <arunisaac@systemreboot.net>2018-04-20 14:49:20 +0530
commit62950ec7e9ad2e5e172cd73a5722348bf60fcc4f (patch)
tree4f0f660d0464801760b3de3a062c565b1bb5542e /gnu
parent9324d92e6a3ef030193f43d21a75ca3e88fa90b4 (diff)
downloadpatches-62950ec7e9ad2e5e172cd73a5722348bf60fcc4f.tar
patches-62950ec7e9ad2e5e172cd73a5722348bf60fcc4f.tar.gz
gnu: Add emacs-kv.
* gnu/packages/emacs.scm (emacs-kv): New variable. Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index d34883b561..8379d69db2 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -7300,6 +7300,32 @@ scratch buffer, and, by virtue of this extension, do so using the Emacs
formatting rules for that language.")
(license license:bsd-2))))
+(define-public emacs-kv
+ (package
+ (name "emacs-kv")
+ (version "0.0.19")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nicferrier/emacs-kv.git")
+ (commit "721148475bce38a70e0b678ba8aa923652e8900e")))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0r0lz2s6gvy04fwnafai668jsf4546h4k6zd6isx5wpk0n33pj5m"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:tests? #t
+ #:test-command '("emacs" "--batch" "-l" "kv-tests.el"
+ "-f" "ert-run-tests-batch-and-exit")))
+ (home-page "https://github.com/nicferrier/emacs-kv")
+ (synopsis "Key/Value data structures library for Emacs Lisp")
+ (description "@code{emacs-kv} is a collection of tools for dealing with
+key/value data structures such as plists, alists and hash-tables in Emacs
+Lisp.")
+ (license license:gpl3+)))
+
(define-public emacs-esxml
(package
(name "emacs-esxml")