summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2018-03-19 21:28:42 -0400
committerArun Isaac <arunisaac@systemreboot.net>2018-04-20 15:38:32 +0530
commit582c122e7b05271d534e1e3a57fac10f2963ca98 (patch)
tree2631b8b37925ff2824c1881b699f14f322b2f047 /gnu
parent9835a71d80c57d26e041abbc6d8ca65e4e1277c6 (diff)
downloadpatches-582c122e7b05271d534e1e3a57fac10f2963ca98.tar
patches-582c122e7b05271d534e1e3a57fac10f2963ca98.tar.gz
gnu: emacs-sx: Fix byte compilation.
The package would fail building when attempting to create a cache directory. This has been fixed upstream but not in a tagged release. * gnu/packages/emacs.scm (emacs-sx): Update to latest git version. Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm43
1 files changed, 24 insertions, 19 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index b8aa9002cf..b72ea0fb3d 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1738,26 +1738,31 @@ strings.")
(license license:gpl2+)))
(define-public emacs-sx
- (package
- (name "emacs-sx")
- (version "0.4")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/vermiculus/sx.el/"
- "archive/v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1w0xghfljqg31axcnv8gzlrd8pw25nji6idnrhflq0af9qh1dw03"))))
- (build-system emacs-build-system)
- (propagated-inputs
- `(("emacs-markdown-mode" ,emacs-markdown-mode)))
- (home-page "https://github.com/vermiculus/sx.el/")
- (synopsis "Emacs StackExchange client")
- (description
- "Emacs StackExchange client. Ask and answer questions on
+ (let ((version "20180212")
+ (revision "1")
+ (commit "833435fbf90d1c9e927d165b155f3b1ef39271de"))
+ (package
+ (name "emacs-sx")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vermiculus/sx.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1369xaxq1vy3d9yh862ddnhddikdpg2d0wv1ly00pnvdp9v4cqgd"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-markdown-mode" ,emacs-markdown-mode)))
+ (home-page "https://github.com/vermiculus/sx.el")
+ (synopsis "Emacs StackExchange client")
+ (description
+ "Emacs StackExchange client. Ask and answer questions on
Stack Overflow, Super User, and other StackExchange sites.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-f
(package