summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2014-05-02 14:11:37 -0500
committerEric Bavier <bavier@member.fsf.org>2014-05-02 14:25:17 -0500
commitf258212df5be894838fc246c387125be7fa65bc0 (patch)
tree4f1e7afcbb2a74d10aa9c67f0db5a403bc303606 /gnu
parent183e44ae4464c7219e9f65dd9c923c3bab2fd732 (diff)
downloadpatches-f258212df5be894838fc246c387125be7fa65bc0.tar
patches-f258212df5be894838fc246c387125be7fa65bc0.tar.gz
gnu: petsc: Add input superlu.
* gnu/packages/maths.scm (petsc): Configure with superlu support.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 991933ad14..99ea1c1c48 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -389,6 +389,7 @@ ASCII text files using Gmsh's own scripting language.")
(inputs
`(("gfortran" ,gfortran-4.8)
("lapack" ,lapack)
+ ("superlu" ,superlu)
;; leaving out hdf5 and fftw, as petsc expects them to be built with mpi
;; leaving out opengl, as configuration seems to only be for mac
))
@@ -397,7 +398,12 @@ ASCII text files using Gmsh's own scripting language.")
#:parallel-build? #f
#:configure-flags
`("--with-mpi=0"
- "--with-openmp=1")
+ "--with-openmp=1"
+ "--with-superlu=1"
+ ,(string-append "--with-superlu-include="
+ (assoc-ref %build-inputs "superlu") "/include")
+ ,(string-append "--with-superlu-lib="
+ (assoc-ref %build-inputs "superlu") "/lib/libsuperlu.a"))
#:phases
(alist-replace
'configure