summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-09-05 09:27:41 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-09-05 23:31:20 -0400
commitdac79ecc513099662c9e4b3219b77ee46e900521 (patch)
tree1c37f0d9e4d7ee3978acf54297508e096b06c1ee /gnu
parent5bf3afea6867627be0aab25cb2eb6aad11f1620c (diff)
downloadpatches-dac79ecc513099662c9e4b3219b77ee46e900521.tar
patches-dac79ecc513099662c9e4b3219b77ee46e900521.tar.gz
gnu: Add python-testresources.
* gnu/packages/python.scm (python-testresources, python2-testresources): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 61127d8ae0..40d979009d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1212,6 +1212,33 @@ style tests.")
(define-public python2-testscenarios
(package-with-python2 python-testscenarios))
+(define-public python-testresources
+ (package
+ (name "python-testresources")
+ (version "0.2.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/t/testresources/testresources-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0cbj3plbllyz42c4b5xxgwaa7mml54lakslrn4kkhinxhdri22md"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page "https://launchpad.net/testresources")
+ (synopsis
+ "Pyunit extension for managing test resources")
+ (description
+ "Testresources is an extension to Python's unittest to allow declarative
+use of resources by test cases.")
+ (license (list bsd-3 asl2.0)))) ; at the user's option
+
+(define-public python2-testresources
+ (package-with-python2 python-testresources))
+
(define-public behave
(package
(name "behave")