summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-09-05 09:45:52 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-09-05 23:31:20 -0400
commit6d45fef43ef2b5fc6e107524d0903a32dcad9999 (patch)
tree378c78a95c6bee62806887389c329ae0b534476e /gnu
parent041358fb01ec18d8f1c6ef57952a24f189d27070 (diff)
downloadpatches-6d45fef43ef2b5fc6e107524d0903a32dcad9999.tar
patches-6d45fef43ef2b5fc6e107524d0903a32dcad9999.tar.gz
gnu: Add python-pyjwt.
* gnu/packages/python.scm (python-pyjwt, python2-pyjwt): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index dbbe794295..3cb69d26ab 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1570,3 +1570,31 @@ somewhat intelligeble.")
(define-public python2-unidecode
(package-with-python2 python-unidecode))
+
+(define-public python-pyjwt
+ (package
+ (name "python-pyjwt")
+ (version "0.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/P/PyJWT/PyJWT-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1ahqblfy2sj3xz34wsa48cn9rp0dspzq56p54i5znmws3b8gml6g"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (arguments
+ '(#:tests? #f)) ; test suite doesn't work
+ (home-page "http://github.com/progrium/pyjwt")
+ (synopsis "JSON Web Token implementation in Python")
+ (description
+ "PyJWT is a JSON Web Token implementation written in Python.")
+ (license expat)))
+
+(define-public python2-pyjwt
+ (package-with-python2 python-pyjwt))
+