summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-09-05 09:57:55 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-09-05 23:31:20 -0400
commit5731cae394767b7f0fd60afdfe722af625083caf (patch)
tree174074dca596879dc4ae2d0bc88337f080215880 /gnu
parentec5dbb5c30ffbde60fb93f91c9149076e498b581 (diff)
downloadpatches-5731cae394767b7f0fd60afdfe722af625083caf.tar
patches-5731cae394767b7f0fd60afdfe722af625083caf.tar.gz
gnu: Add python-virtualenv.
* gnu/packages/python.scm (python-virtualenv, python2-virtualenv): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 6ba8c243f4..a4e9014e4d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1669,3 +1669,30 @@ environments and back.")
(define-public python2-itsdangerous
(package-with-python2 python-itsdangerous))
+
+(define-public python-virtualenv
+ (package
+ (name "python-virtualenv")
+ (version "1.11.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/v/virtualenv/virtualenv-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1xq4prmg25n9cz5zcvbqx68lmc3kl39by582vd8pzs9f3qalqyiy"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)
+ ("python-mock" ,python-mock)
+ ("python-nose" ,python-nose)))
+ (home-page "https://virtualenv.pypa.io/")
+ (synopsis "Virtual Python environment builder")
+ (description
+ "Virtualenv is a tool to create isolated Python environments.")
+ (license expat)))
+
+(define-public python2-virtualenv
+ (package-with-python2 python-virtualenv))