summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-09-05 08:39:43 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-09-05 23:31:20 -0400
commit4435427e6d87a2b153dffd43a34f3ab234564cc7 (patch)
treee9fe8214dcefb774310aa3dc68cee013356066b7 /gnu
parentc15a5c0eaca0310e54a1352da5a65cc8df76c084 (diff)
downloadpatches-4435427e6d87a2b153dffd43a34f3ab234564cc7.tar
patches-4435427e6d87a2b153dffd43a34f3ab234564cc7.tar.gz
gnu: Add python-nose.
* gnu/packages/python.scm (python-nose, python2-nose): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm29
1 files changed, 28 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 7048b5babc..0208354205 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -23,7 +23,7 @@
(define-module (gnu packages python)
#:use-module ((guix licenses)
#:select (asl2.0 bsd-3 bsd-style cc0 expat x11 x11-style
- gpl2 gpl2+ lgpl2.1+
+ gpl2 gpl2+ lgpl2.0+ lgpl2.1+
psfl public-domain))
#:use-module ((guix licenses) #:select (zlib)
#:renamer (symbol-prefix-proc 'license:))
@@ -996,6 +996,33 @@ matching them against a list of media-ranges.")
(define-public python2-mimeparse
(package-with-python2 python-mimeparse))
+(define-public python-nose
+ (package
+ (name "python-nose")
+ (version "1.3.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/n/nose/nose-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "00qymfgwg4iam4xi0w9bnv7lcb3fypq1hzfafzgs1rfmwaj67g3n"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (arguments
+ '(#:tests? #f)) ; FIXME: test suite fails
+ (home-page "http://readthedocs.org/docs/nose/")
+ (synopsis "Python testing library")
+ (description
+ "Nose extends the unittest library to make testing easier.")
+ (license lgpl2.0+)))
+
+(define-public python2-nose
+ (package-with-python2 python-nose))
+
(define-public behave
(package
(name "behave")