summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRene Saavedra <rennes@openmailbox.org>2016-03-29 22:04:49 +0200
committerLudovic Courtès <ludo@gnu.org>2016-03-29 22:13:20 +0200
commit3a9a4c51e8ddc5b4282de7a37cdb96e878a7feed (patch)
tree1c4552a6998afbf0e13603d20fe34e2019662626 /gnu
parentb7fbf297c8e1128b2d09cc9833a267e7e510961b (diff)
downloadpatches-3a9a4c51e8ddc5b4282de7a37cdb96e878a7feed.tar
patches-3a9a4c51e8ddc5b4282de7a37cdb96e878a7feed.tar.gz
gnu: Add libzapojit.
* gnu/packages/gnome.scm (libzapojit): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index eebb547de3..11ed4868b0 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Rene Saavedra <rennes@openmailbox.org>
;;; Copyright © 2016 Jochem Raat <jchmrt@riseup.net>
+;;; Copyright © 2016 Rene Saavedra <rennes@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4928,3 +4929,31 @@ command-line interface. It can record part or all of an X display for a
specified duration and save it as a GIF encoded animated image file.")
(home-page "https://git.gnome.org/browse/byzanz")
(license license:gpl2+))))
+
+(define-public libzapojit
+ (package
+ (name "libzapojit")
+ (version "0.0.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0zn3s7ryjc3k1abj4k55dr2na844l451nrg9s6cvnnhh569zj99x"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("gobject-introspection" ,gobject-introspection)
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gnome-online-accounts" ,gnome-online-accounts)
+ ("json-glib" ,json-glib)
+ ("rest" ,rest)))
+ (home-page "https://wiki.gnome.org/Projects/Zapojit")
+ (synopsis "Library for accessing SkyDrive and Hotmail")
+ (description
+ "Libzapojit is a GLib-based library for accessing online service APIs of
+Microsoft SkyDrive and Hotmail, using their REST protocols.")
+ (license license:lgpl2.1+)))