summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-09-02 21:22:14 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-09-05 23:31:20 -0400
commit3a1f9a68e5c75097f94f193f96350db97723f027 (patch)
tree8585725a1b82c2a59132b1a325d75dce07a13249 /gnu
parentd5f89b22d82fb1c7f41b784f2711d898ce81396b (diff)
downloadpatches-3a1f9a68e5c75097f94f193f96350db97723f027.tar
patches-3a1f9a68e5c75097f94f193f96350db97723f027.tar.gz
gnu: Add python-certifi.
* gnu/packages/python.scm (python-certifi, python2-certifi): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ad5def2a8c..766ce16551 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1021,3 +1021,30 @@ files.")
(define-public python2-pyld
(package-with-python2 python-pyld))
+
+(define-public python-certifi
+ (package
+ (name "python-certifi")
+ (version "14.05.14")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "https://pypi.python.org/packages/source/c/certifi/certifi-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0s8vxzfz6s4m6fvxc7z25k9j35w0rh6jkw3wwcd1az1mssncn6qy"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (arguments `(#:tests? #f)) ; no tests
+ (home-page "http://python-requests.org/")
+ (synopsis "Python CA certificate bundle")
+ (description
+ "Certifi is a Python library that contains a CA certificate bundle, which
+is used by the Requests library to verify HTTPS requests.")
+ (license asl2.0)))
+
+(define-public python2-certifi
+ (package-with-python2 python-certifi))