summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-08-28 23:46:57 +0000
committerAlex Kost <alezost@gmail.com>2016-08-31 10:10:30 +0300
commit9657aba4ed92d4965e89122dc086f96f1f06d3fc (patch)
tree7ce405f5f086632f3365360d545009f2ec771ee5 /gnu
parent41392b9a3d715daac76f92092323fdeb8cf8ad3a (diff)
downloadpatches-9657aba4ed92d4965e89122dc086f96f1f06d3fc.tar
patches-9657aba4ed92d4965e89122dc086f96f1f06d3fc.tar.gz
gnu: Add emacs-cyberpunk-theme.
* gnu/packages/emacs.scm (emacs-cyberpunk-theme): New variable. Signed-off-by: Alex Kost <alezost@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 6485beef6b..3088c0a566 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -3026,3 +3026,24 @@ and contiguous matches (substring). The longer the substring match,
the higher it scores. This maps well to how we think about matching.
Flx has support for ido (interactively do things) through flx-ido.")
(license license:gpl3+)))
+
+(define-public emacs-cyberpunk-theme
+ (package
+ (name "emacs-cyberpunk-theme")
+ (version "1.17")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/n3mo/cyberpunk-theme.el/"
+ "archive/" version ".tar.gz"))
+ (sha256
+ (base32
+ "068jcn4g1bvwgpcvyfqygzw6ahill51c1sqzyyvj2paxckbd7h51"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/n3mo/cyberpunk-theme.el")
+ (synopsis "Cyberpunk theme for emacs built-in color theme support")
+ (description
+ "Cyberpunk color theme for the emacs 24+ built-in color theme support
+known loosely as deftheme. Many mode-specific customizations are included.")
+ (license license:gpl3+)))