summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:29:40 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:10 +0200
commitd6c0f1bc94ce96a46ad05731446c8a301f3343dc (patch)
tree46cdaef2759e35ef4c8f9d716d551665fb9b26d2 /gnu
parent5da3df8f48c5fa6c2e40014a9d9529e83e7e7a36 (diff)
downloadpatches-d6c0f1bc94ce96a46ad05731446c8a301f3343dc.tar
patches-d6c0f1bc94ce96a46ad05731446c8a301f3343dc.tar.gz
gnu: emacs-json-snatcher: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-json-snatcher)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 92bb808cf8..fa8cd5e947 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -7419,13 +7419,13 @@ running a customisable handler command (@code{ignore} by default). ")
(version "1.0.0")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/Sterlingg/json-snatcher/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Sterlingg/json-snatcher.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "1nfiwsifpdiz0lbrqa77nl0crnfrv5h85ans9b0g5rggnmyshcfb"))))
+ (base32 "05zsgnk7grgw9jzwl80h5sxfpifxlr37b4mkbvx7mjq4z14xc2jw"))))
(build-system emacs-build-system)
(home-page "https://github.com/sterlingg/json-snatcher")
(synopsis "Grabs the path to JSON values in a JSON file")