summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-12-12 00:58:05 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-12-12 01:08:06 +0100
commiteb6263f215799e5c072380be40a0826f17da9821 (patch)
treea8c13d3333494257d1638532431bb514ef04d81e /gnu
parentf419fe4ddb55e2c78243ba4c66a3483e21662ee0 (diff)
downloadpatches-eb6263f215799e5c072380be40a0826f17da9821.tar
patches-eb6263f215799e5c072380be40a0826f17da9821.tar.gz
gnu: whois: Update to 5.2.19.
* gnu/packages/networking.scm (whois): Update to 5.2.19. [arguments]: Don't set HAVE_LIBIDN in 'setenv' phase; this is now autodetected. [native-inputs]: Add PKG-CONFIG.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/networking.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index c60f255c3d..2538f7831d 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -450,7 +450,7 @@ and up to 1 Mbit/s downstream.")
(define-public whois
(package
(name "whois")
- (version "5.2.18")
+ (version "5.2.19")
(source
(origin
(method url-fetch)
@@ -458,7 +458,7 @@ and up to 1 Mbit/s downstream.")
name "_" version ".tar.xz"))
(sha256
(base32
- "1mcpgj18n1xppvlhjqzpj05yr5z48bym9bd88k10fwgkmwk0spf3"))))
+ "0b16w48c17k35lhd95qcl2kjq2rahk8znkg3w467rf3kzmsa4fbc"))))
(build-system gnu-build-system)
;; TODO: unbundle mkpasswd binary + its po files.
(arguments
@@ -471,13 +471,14 @@ and up to 1 Mbit/s downstream.")
(add-before 'build 'setenv
(lambda _
(setenv "HAVE_ICONV" "1")
- (setenv "HAVE_LIBIDN" "1")
#t)))))
(inputs
+ ;; TODO: Switch to libidn2 when >= 2.0.3 is ungrafted in master.
`(("libidn" ,libidn)))
(native-inputs
`(("gettext" ,gettext-minimal)
- ("perl" ,perl)))
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)))
(synopsis "Improved whois client")
(description "This whois client is intelligent and can
automatically select the appropriate whois server for most queries.