summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-06-26 15:22:03 +0200
committerLudovic Courtès <ludo@gnu.org>2019-06-26 15:59:58 +0200
commit83817158b20d90a918e12ad3fae0d357dac4e083 (patch)
tree5e300c52877b006831f7ad5160100bd3d38c8d72 /gnu
parent5d5edb88bd3bf45fe07becccc24790dca525516a (diff)
downloadpatches-83817158b20d90a918e12ad3fae0d357dac4e083.tar
patches-83817158b20d90a918e12ad3fae0d357dac4e083.tar.gz
gnu: python-on-guile: Wrap 'python' executable.
* gnu/packages/guile-xyz.scm (python-on-guile)[arguments]: Add 'wrap' phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/guile-xyz.scm17
1 files changed, 14 insertions, 3 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 877551ea3b..a8352380f7 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -2187,12 +2187,23 @@ serializing continuations or delimited continuations.")
(build-system gnu-build-system)
(arguments
`(#:parallel-build? #f ; not supported
- #:make-flags
- '("GUILE_AUTO_COMPILE=0") ; to prevent guild errors
+ #:make-flags '("GUILE_AUTO_COMPILE=0") ;to prevent guild warnings
+
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'chdir
- (lambda _ (chdir "modules") #t)))))
+ (lambda _ (chdir "modules") #t))
+ (add-after 'install 'wrap
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Wrap the 'python' executable so it can find its
+ ;; dependencies.
+ (let ((out (assoc-ref outputs "out")))
+ (wrap-program (string-append out "/bin/python")
+ `("GUILE_LOAD_PATH" ":" prefix
+ (,(getenv "GUILE_LOAD_PATH")))
+ `("GUILE_LOAD_COMPILED_PATH" ":" prefix
+ (,(getenv "GUILE_LOAD_COMPILED_PATH"))))
+ #t))))))
(inputs
`(("guile" ,guile-2.2)))
(propagated-inputs