summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-10-02 22:22:21 +0200
committerAndreas Enge <andreas@enge.fr>2013-10-02 22:22:21 +0200
commit7d3f36518dc3314c2023ac5ad17383978b559a77 (patch)
tree9f3873f320693fd6c1a89d0e7c5cdba08d92ddc2 /gnu
parent27477d2de087fd69227ccce49888cb8c2805f827 (diff)
downloadpatches-7d3f36518dc3314c2023ac5ad17383978b559a77.tar
patches-7d3f36518dc3314c2023ac5ad17383978b559a77.tar.gz
gnu: gnome: Add gnome-icon-theme.
* gnu/packages/gnome.scm (gnome-icon-theme): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm28
1 files changed, 27 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c74761d218..66d4b4ee0d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -17,7 +17,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages gnome)
- #:use-module ((guix licenses) #:select (gpl2+ lgpl2.1+))
+ #:use-module ((guix licenses) #:select (gpl2+ lgpl2.1+ lgpl3))
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
@@ -110,6 +110,32 @@ Specification, the icon naming utility maps the icon names used by the
GNOME and KDE desktops to the icon names proposed in the specification.")
(license lgpl2.1+)))
+(define-public gnome-icon-theme
+ (package
+ (name "gnome-icon-theme")
+ (version "3.10.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (string-copy version 0 (string-rindex version #\.)) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1xinbgkkvlhazj887ajcl13i7kdc1wcca02jwxzvjrvchjsp4m66"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("gtk+" ,gtk+)
+ ("icon-naming-utils" ,icon-naming-utils)
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (home-page "http://art.gnome.org/")
+ (synopsis
+ "GNOME icon theme")
+ (description
+ "Icons for the GNOME desktop.")
+ (license lgpl3))) ; or Creative Commons BY-SA 3.0
+
(define-public libnotify
(package
(name "libnotify")