summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-16 18:18:21 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-16 18:34:49 +0100
commit46c1c5537b3c140b1e597a020f38c77fb97f26ec (patch)
tree76b4f5059ccfa3b7cdd1381f76cf239712c111da /gnu
parent9adb66dd11ba36b05d090fdc754e1cde0ff1c72f (diff)
downloadpatches-46c1c5537b3c140b1e597a020f38c77fb97f26ec.tar
patches-46c1c5537b3c140b1e597a020f38c77fb97f26ec.tar.gz
gnu: stumpwm: Build and install the manual.
* gnu/packages/lisp.scm (stumpwm)[native-inputs]: Add texinfo. [argument]: Add new ‘install-manual’ phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp.scm15
1 files changed, 13 insertions, 2 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 93dc1aaf80..5aad298399 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2016, 2017 Andy Patterson <ajpatter@uwaterloo.ca>
;;; Copyright © 2017, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Benjamin Slade <slade@jnanam.net>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
@@ -984,7 +984,8 @@ from other CLXes around the net.")
;; and can be removed when we move to the next release.
(search-patches "stumpwm-fix-broken-read-one-line.patch"))))
(build-system asdf-build-system/sbcl)
- (native-inputs `(("fiasco" ,sbcl-fiasco)))
+ (native-inputs `(("fiasco" ,sbcl-fiasco)
+ ("texinfo" ,texinfo)))
(inputs `(("cl-ppcre" ,sbcl-cl-ppcre)
("clx" ,sbcl-clx)
("alexandria" ,sbcl-alexandria)))
@@ -1016,6 +1017,16 @@ from other CLXes around the net.")
Icon=~@
Type=Application~%"
out)))
+ #t)))
+ (add-after 'install 'install-manual
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; The proper way to the manual is bootstrapping a full autotools
+ ;; build system and running ‘./configure && make stumpwm.info’ to
+ ;; do some macro substitution. We can get away with much less.
+ (let* ((out (assoc-ref outputs "out"))
+ (info (string-append out "/share/info")))
+ (invoke "makeinfo" "stumpwm.texi.in")
+ (install-file "stumpwm.info" info)
#t))))))
(synopsis "Window manager written in Common Lisp")
(description "Stumpwm is a window manager written entirely in Common Lisp.