summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-02-15 00:26:52 +0100
committerLudovic Courtès <ludo@gnu.org>2013-02-15 00:52:54 +0100
commit1dee732b81660ad2f6b4831c7e53c61e5ca32a0f (patch)
tree9d7b4e012a2413df50074dcf3f1612b3c94b9cf9 /gnu
parenteb4908581cae8b787c63b39fa524adf764ae8c25 (diff)
downloadpatches-1dee732b81660ad2f6b4831c7e53c61e5ca32a0f.tar
patches-1dee732b81660ad2f6b4831c7e53c61e5ca32a0f.tar.gz
gnu: linux-libre: Choose a config without debugging features.
* gnu/packages/linux.scm (linux-libre): Choose "defconfig" instead of "allmodconfig" since the latter enables all debugging features. Add `CONFIG_CIFS=m'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f3e7d18627..b97315580b 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -133,7 +133,13 @@
(format #t "`ARCH' set to `~a'~%" (getenv "ARCH")))
(let ((build (assoc-ref %standard-phases 'build)))
- (and (zero? (system* "make" "allmodconfig"))
+ (and (zero? (system* "make" "defconfig"))
+ (begin
+ (format #t "enabling additional modules...~%")
+ (substitute* ".config"
+ (("^# CONFIG_CIFS.*$")
+ "CONFIG_CIFS=m\n"))
+ (zero? (system* "make" "oldconfig")))
;; Call the default `build' phase so `-j' is correctly
;; passed.