summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-05-03 14:28:09 +0200
committerAndreas Enge <andreas@enge.fr>2015-05-03 14:28:09 +0200
commitfc15db2f7dbac8f606bea54b58138f2ae84c1e73 (patch)
tree515b5d0e5dd22fc3160ec9fb3b8ab4f9136f9445 /gnu
parent10ca4a1d4bed5105826e0637a656f0dbb52387e7 (diff)
downloadpatches-fc15db2f7dbac8f606bea54b58138f2ae84c1e73.tar
patches-fc15db2f7dbac8f606bea54b58138f2ae84c1e73.tar.gz
gnu: Add libwpd.
* gnu/packages/libreoffice.scm (libwpd): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/libreoffice.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 8daa0e99a1..4de5fcaadd 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -110,3 +110,28 @@ CSV, CSS and XML.")
filters. It has interfaces for text documents, vector graphics,
spreadsheets and presentations.")
(license '(mpl2.0 lgpl2.1+)))) ; dually licensed
+
+(define-public libwpd
+ (package
+ (name "libwpd")
+ (version "0.10.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/libwpd/" name "/" name "-"
+ version ".tar.xz"))
+ (sha256 (base32
+ "0b6krzr6kxzm89g6bapn805kdayq70hn16n5b5wfs2lwrf0ag2wx"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("doxygen" ,doxygen)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("librevenge" ,librevenge)
+ ("zlib" ,zlib)))
+ (home-page "http://libwpd.sourceforge.net/")
+ (synopsis "Library for importing WordPerfect documents")
+ (description "Libwpd is a C++ library designed to help process
+WordPerfect documents. It is most commonly used to import such documents
+into other word processors.")
+ (license '(mpl2.0 lgpl2.1+)))) ; dually licensed