summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-05-09 08:42:57 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-05-15 22:33:14 +0200
commit37e2e5d43401da93eebd21c08d1b6a73b9982b13 (patch)
tree6e2df5780d7821eba9fa2a40e58902b4b6bd1014 /gnu
parent6ee6d0b58a022d2a659304496e9a304d1b20663e (diff)
downloadpatches-37e2e5d43401da93eebd21c08d1b6a73b9982b13.tar
patches-37e2e5d43401da93eebd21c08d1b6a73b9982b13.tar.gz
gnu: Add java-osgi-core.
* gnu/packages/java.scm (java-osgi-core): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 26d251f138..d5b2d61bde 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2317,6 +2317,32 @@ the OSGi annotation module, providing additional services to help dynamic
components.")
(license license:asl2.0)))
+(define-public java-osgi-core
+ (package
+ (name "java-osgi-core")
+ (version "6.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://repo1.maven.org/maven2/"
+ "org/osgi/org.osgi.core/" version "/"
+ "org.osgi.core-" version "-sources.jar"))
+ (sha256
+ (base32
+ "19bpf5jx32jq9789gyhin35q5v7flmw0p9mk7wbgqpxqfmxyiabv"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:jar-name "osgi-core.jar"))
+ (inputs
+ `(("java-osgi-annotation" ,java-osgi-annotation)))
+ (home-page "http://www.osgi.org")
+ (synopsis "Core module of OSGi framework")
+ (description
+ "OSGi, for Open Services Gateway initiative framework, is a module system
+and service platform for the Java programming language. This package contains
+the OSGi Core module.")
+ (license license:asl2.0)))
+
(define-public java-commons-cli
(package
(name "java-commons-cli")