summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorValentin Ignatev <valentignatev@gmail.com>2020-01-19 15:51:59 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-02-23 17:08:40 +0200
commitb85417d972a02abc4e309912433fb1f080a694b0 (patch)
tree9d09390e57ee7243eb088cde66cb9a257bd83c6c /gnu
parent40cae204b994300452571f2c9e86d7dc6b83f627 (diff)
downloadpatches-b85417d972a02abc4e309912433fb1f080a694b0.tar
patches-b85417d972a02abc4e309912433fb1f080a694b0.tar.gz
gnu: Add rust-futures-executor-0.3.
* gnu/packages/crates-io.scm (rust-futures-executor-0.3): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 84a61739ba..18c8f9ad0f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -4684,6 +4684,34 @@ the computation on the threads themselves.")
(license (list license:asl2.0
license:expat))))
+(define-public rust-futures-executor-0.3
+ (package
+ (name "rust-futures-executor")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "futures-executor" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0cf24wbgxqh4kdjbb557vk1axzmbpmwb8s05ga1nls1zaqv4f9qy"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:tests? #f
+ #:cargo-inputs
+ (("rust-futures-core" ,rust-futures-core-0.3)
+ ("rust-futures-task" ,rust-futures-task-0.3)
+ ("rust-futures-util" ,rust-futures-util-0.3)
+ ("rust-num-cpus" ,rust-num-cpus-1.11))))
+ (home-page "https://rust-lang-nursery.github.io/futures-rs")
+ (synopsis "Executors for asynchronous tasks based on the futures-rs library")
+ (description
+ "This package provides executors for asynchronous tasks based on the
+@code{futures-rs} library.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-futures-executor-preview-0.3
(package
(name "rust-futures-executor-preview")