summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-28 22:12:52 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-28 23:05:05 +0100
commitc1cb8576453db450493726ab44f34910dfa10ed7 (patch)
tree6c8e57501b0b2b20b42219b8ea524ba268323ba5 /gnu
parent9d43579f2d7d517de3a67c41b2429b467c651514 (diff)
downloadpatches-c1cb8576453db450493726ab44f34910dfa10ed7.tar
patches-c1cb8576453db450493726ab44f34910dfa10ed7.tar.gz
gnu: Add java-ecj-3.
* gnu/packages/java.scm (java-ecj-3): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 2b7a76fda3..4ea6f4d8c3 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2018,6 +2018,41 @@ debugging, etc.")
(delete-file-recursively "lib") #t))
(replace 'install (install-jars "bin/lib")))))))
+;; This is the last 3.x release of ECJ
+(define-public java-ecj-3
+ (package
+ (name "java-ecj")
+ (version "3.8.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://archive.eclipse.org/eclipse/"
+ "downloads/drops/R-" version
+ "-201301310800/ecjsrc-" version ".jar"))
+ (sha256
+ (base32
+ "01mdj14jw11g1jfnki4fi8229p0c6zzckd38zqy2w4m3cjcvsx04"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:tests? #f ; none included
+ #:jdk ,icedtea-7 ; doesn't build with JDK8+
+ #:make-flags (list "-f" "src/build.xml")
+ #:build-target "build"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-manifest
+ (lambda _
+ ;; Record the main class to make ecj executable.
+ (with-atomic-file-replacement "src/META-INF/MANIFEST.MF"
+ (lambda (in out)
+ (display "Manifest-Version: 1.0
+Main-Class: org.eclipse.jdt.internal.compiler.batch.Main\n"
+ out)))))
+ (replace 'install (install-jars ".")))))
+ (home-page "https://eclipse.org")
+ (synopsis "Eclipse Java development tools core batch compiler")
+ (description "This package provides the Eclipse Java core batch compiler.")
+ (license license:epl1.0)))
+
(define-public java-classpathx-servletapi
(package
(name "java-classpathx-servletapi")