summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-09-06 15:00:16 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-09-06 15:00:49 +0200
commit8205534569cb2a09d53b7c925a349cd7f4e3599d (patch)
treea2c98a641bd8ef45acaf0451e7745bf82aea1f1a /gnu
parent7cd446fd3f1d3b5dce4800d1daba2fa31a07f1b2 (diff)
downloadpatches-8205534569cb2a09d53b7c925a349cd7f4e3599d.tar
patches-8205534569cb2a09d53b7c925a349cd7f4e3599d.tar.gz
gnu: Add samblaster.
* gnu/packages/bioinformatics.scm (samblaster): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f98f10a2c3..cf2dc57fa7 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -15232,3 +15232,37 @@ indels (insertions and deletions), MNPs (multi-nucleotide polymorphisms), and
complex events (composite insertion and substitution events) smaller than the
length of a short-read sequencing alignment.")
(license license:expat))))
+
+(define-public samblaster
+ (package
+ (name "samblaster")
+ (version "0.1.24")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/GregoryFaust/samblaster.git")
+ (commit (string-append "v." version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0iv2ddfw8363vb2x8gr3p8g88whb6mb9m0pf71i2cqsbv6jghap7"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; there are none
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; There is no configure phase.
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (install-file "samblaster"
+ (string-append (assoc-ref outputs "out") "/bin"))
+ #t)))))
+ (home-page "https://github.com/GregoryFaust/samblaster")
+ (synopsis "Mark duplicates in paired-end SAM files")
+ (description "Samblaster is a fast and flexible program for marking
+duplicates in read-id grouped paired-end SAM files. It can also optionally
+output discordant read pairs and/or split read mappings to separate SAM files,
+and/or unmapped/clipped reads to a separate FASTQ file. When marking
+duplicates, samblaster will require approximately 20MB of memory per 1M read
+pairs.")
+ (license license:expat)))