summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-01-21 20:21:19 -0500
committerLeo Famulari <leo@famulari.name>2016-01-21 20:21:19 -0500
commit765973cd651d597bf9cd42ea05b50c5a8ebee2f3 (patch)
treee43ad8597007b08cde280db02545a6f24faf3562 /gnu
parentc2af02602ab19deca27db776406b35860cf47d97 (diff)
downloadpatches-765973cd651d597bf9cd42ea05b50c5a8ebee2f3.tar
patches-765973cd651d597bf9cd42ea05b50c5a8ebee2f3.tar.gz
gnu: Add iftop.
* gnu/packages/admin.scm (iftop): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/admin.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 6e783502e6..953c5b4cf8 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2015 Alex Sassmannshausen <alex.sassmannshausen@gmail.com>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
+;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1377,3 +1378,25 @@ command that learns\". It works by maintaining a database of the directories
you use the most from the command line and allows you to \"jump\" to
frequently used directories by typing only a small pattern.")
(license license:gpl3+)))
+
+(define-public iftop
+ (package
+ (name "iftop")
+ (version "1.0pre4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.ex-parrot.com/~pdw/iftop/download"
+ "/iftop-" version ".tar.gz"))
+ (sha256
+ (base32
+ "15sgkdyijb7vbxpxjavh5qm5nvyii3fqcg9mzvw7fx8s6zmfwczp"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libpcap" ,libpcap)
+ ("ncurses" ,ncurses)))
+ (synopsis "Monitor network usage")
+ (description "Iftop does for network usage what @command{top} does
+for CPU usage. It listens to network traffic on a named interface and
+displays a table of current bandwidth usage by pairs of hosts.")
+ (home-page "http://www.ex-parrot.com/~pdw/iftop/")
+ (license license:gpl3)))