summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-01-31 18:22:04 +0100
committerLudovic Courtès <ludo@gnu.org>2014-01-31 18:22:04 +0100
commite420308f292cc55bbc21d0907a3a02779b4527e1 (patch)
tree9e703cec7f8e70741476a2e43d2c20c98160b2a5 /gnu
parentfd3bfc44ff65e166d1c515721c7870391dceb799 (diff)
downloadpatches-e420308f292cc55bbc21d0907a3a02779b4527e1.tar
patches-e420308f292cc55bbc21d0907a3a02779b4527e1.tar.gz
gnu: xorg-server: Use /var as $localstatedir.
* gnu/packages/xorg.scm (xorg-server): Pass --localstatedir=/var. In 'configure' phase, patch 'hw/xfree86/Makefile.in'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xorg.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 6c17170eef..fbb6367d05 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -4377,7 +4377,10 @@ tracking.")
; the compiled keyboard maps go?
(string-append "--with-xkb-bin-directory="
(assoc-ref %build-inputs "xkbcomp")
- "/bin"))
+ "/bin")
+
+ ;; For the log file, etc.
+ "--localstatedir=/var")
#:phases
(alist-replace
'configure
@@ -4385,6 +4388,12 @@ tracking.")
(let ((configure (assoc-ref %standard-phases 'configure)))
(substitute* (find-files "." "\\.c$")
(("/bin/sh") (which "sh")))
+
+ ;; Don't try to 'mkdir /var'.
+ (substitute* "hw/xfree86/Makefile.in"
+ (("mkdir(.*)logdir.*")
+ "true\n"))
+
(apply configure args)))
%standard-phases)))
(home-page "http://www.x.org/wiki/")