summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBrian Leung <brian@debian>2019-12-03 22:44:12 -0800
committerBrian Leung <brian@debian>2019-12-07 22:16:34 -0800
commit6165fb240bde1a66b4ca7cb56f6b13f0c7a567d5 (patch)
tree44b4a4b051d167ef81bc559aedbcc33de03939f8 /gnu
parente8da79ab6ff8a725e20863ef5d36ff350d5f2791 (diff)
downloadpatches-6165fb240bde1a66b4ca7cb56f6b13f0c7a567d5.tar
patches-6165fb240bde1a66b4ca7cb56f6b13f0c7a567d5.tar.gz
gnu: Add emacs-isearch-dabbrev.
* gnu/packages/emacs-xyz.scm (emacs-isearch-dabbrev): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f03505b8fa..bf82cf4f3c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -20346,3 +20346,26 @@ items.")
by @code{zsh} as well as @code{eldoc} support.")
(home-page "https://github.com/tom-tan/esh-help")
(license license:gpl3+))))
+
+(define-public emacs-isearch-dabbrev
+ (let ((commit "1efe7abba4923015cbc2462395deaec5446a9cc8")
+ (revision "1"))
+ (package
+ (name "emacs-isearch-dabbrev")
+ (version (git-version "0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Dewdrops/isearch-dabbrev.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "17d0816awadvsw1qc7r0p6ira75jmgxaj9hsk9ypayxsaf6ynyrb"))))
+ (build-system emacs-build-system)
+ (synopsis "Use @code{dabbrev} within @code{isearch}")
+ (description "This package allows @code{dabbrev-expand} to be used
+within @code{isearch-mode}.")
+ (home-page "https://github.com/Dewdrops/isearch-dabbrev")
+ (license license:gpl3+))))