summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-09-05 08:45:24 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-09-05 23:31:20 -0400
commit6cd9c356374a5af6cf4b51f6688b34933e36c982 (patch)
tree31b9e662e056e3154679ebc16fde4fd57b105ea8 /gnu
parent4435427e6d87a2b153dffd43a34f3ab234564cc7 (diff)
downloadpatches-6cd9c356374a5af6cf4b51f6688b34933e36c982.tar
patches-6cd9c356374a5af6cf4b51f6688b34933e36c982.tar.gz
gnu: Add python-unittest2.
* gnu/packages/python.scm (python-unittest2, python2-unittest2): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 0208354205..fd8c6fefae 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1023,6 +1023,48 @@ matching them against a list of media-ranges.")
(define-public python2-nose
(package-with-python2 python-nose))
+(define-public python-unittest2
+ (package
+ (name "python-unittest2")
+ (version "0.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/u/unittest2py3k/unittest2py3k-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "00yl6lskygcrddx5zspkhr0ibgvpknl4678kkm6s626539grq93q"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page "http://pypi.python.org/pypi/unittest2")
+ (synopsis "Python unit testing library")
+ (description
+ "Unittest2 is a replacement for the unittest module in the Python
+standard library.")
+ (license psfl)))
+
+(define-public python2-unittest2
+ (package (inherit python-unittest2)
+ (name "python2-unittest2")
+ (version "0.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/u/unittest2/unittest2-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0wbs4i4x3x7klr3v35ss6p9mcqz883i1xgcpkhvl7n2lyv6yhpda"))))
+ (inputs
+ `(("python2-setuptools" ,python-setuptools)))
+ (arguments
+ `(#:python ,python-2
+ #:tests? #f)))) ; no setup.py test command
+
(define-public behave
(package
(name "behave")