summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-09-05 08:59:37 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-09-05 23:31:20 -0400
commit542ad60fbc7de02d86ff61e061af9aa5f6a47453 (patch)
tree149acf84076c0c128fd2519f3cfad21c09c7fa86 /gnu
parent6cd9c356374a5af6cf4b51f6688b34933e36c982 (diff)
downloadpatches-542ad60fbc7de02d86ff61e061af9aa5f6a47453.tar
patches-542ad60fbc7de02d86ff61e061af9aa5f6a47453.tar.gz
gnu: Add python-py.
* gnu/packages/python.scm (python-py, python2-py): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index fd8c6fefae..3edc9b1581 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1065,6 +1065,32 @@ standard library.")
`(#:python ,python-2
#:tests? #f)))) ; no setup.py test command
+(define-public python-py
+ (package
+ (name "python-py")
+ (version "1.4.23")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/p/py/py-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1jkhffpai419v5rickm2vz86p9bkg3b3kcm2k4bi5wfajhw2m3xs"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page "http://pylib.readthedocs.org/")
+ (synopsis "Python library for parsing, I/O, instrospection, and logging")
+ (description
+ "Py is a Python library for file name parsing, .ini file parsing, I/O,
+code introspection, and logging.")
+ (license expat)))
+
+(define-public python2-py
+ (package-with-python2 python-py))
+
(define-public behave
(package
(name "behave")