summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-09-05 20:49:54 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-09-05 23:31:20 -0400
commit041358fb01ec18d8f1c6ef57952a24f189d27070 (patch)
tree86e61f47c2bada21accfe2091152488ca4595098 /gnu
parent243a009adacd85b6e742b754433d99624742c840 (diff)
downloadpatches-041358fb01ec18d8f1c6ef57952a24f189d27070.tar
patches-041358fb01ec18d8f1c6ef57952a24f189d27070.tar.gz
gnu: Add python-discover.
* gnu/packages/python.scm (python-discover, python2-discover): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 4577940946..dbbe794295 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1354,6 +1354,33 @@ executed.")
(define-public python2-coverage
(package-with-python2 python-coverage))
+(define-public python-discover
+ (package
+ (name "python-discover")
+ (version "0.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/d/discover/discover-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0y8d0zwiqar51kxj8lzmkvwc3b8kazb04gk5zcb4nzg5k68zmhq5"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page "http://pypi.python.org/pypi/discover/")
+ (synopsis
+ "Python test discovery for unittest")
+ (description
+ "Discover provides test discovery for unittest, a feature that has been
+backported from Python 2.7 for Python 2.4+")
+ (license bsd-3)))
+
+(define-public python2-discover
+ (package-with-python2 python-discover))
+
(define-public behave
(package
(name "behave")