summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-11-24 14:03:26 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-11-25 14:05:32 +0100
commit46130b7bee382c6f9de8f80fb0f067253fcd9ca9 (patch)
tree4e390de30687eb529902847321623944bd0c89a7 /gnu
parentaca2bf51b767bfdc152896430f83b7c1124c346d (diff)
downloadpatches-46130b7bee382c6f9de8f80fb0f067253fcd9ca9.tar
patches-46130b7bee382c6f9de8f80fb0f067253fcd9ca9.tar.gz
gnu: r-scales: Move to (gnu packages cran).
* gnu/packages/statistics.scm (r-scales): Move variable from here... * gnu/packages/cran.scm (r-scales): ...to here.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm27
-rw-r--r--gnu/packages/statistics.scm26
2 files changed, 27 insertions, 26 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 7715b1cf63..947d60721f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015, 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016, 2017 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2017, 2018 Roel Janssen <roel@gnu.org>
;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -95,6 +96,32 @@
the system clipboards.")
(license license:gpl3)))
+(define-public r-scales
+ (package
+ (name "r-scales")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "scales" version))
+ (sha256
+ (base32 "0353dkh3d7x78463c6ds80hcml59lrqwr8rlv82a8dnkxla4l7qc"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-labeling" ,r-labeling)
+ ("r-munsell" ,r-munsell)
+ ("r-rcolorbrewer" ,r-rcolorbrewer)
+ ("r-rcpp" ,r-rcpp)
+ ("r-r6" ,r-r6)
+ ("r-viridislite" ,r-viridislite)))
+ (home-page "https://github.com/hadley/scales")
+ (synopsis "Scale functions for visualization")
+ (description
+ "This package provides graphical scales that map data to aesthetics, and
+provides methods for automatically determining breaks and labels for axes and
+legends.")
+ (license license:expat)))
+
(define-public r-ellipsis
(package
(name "r-ellipsis")
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 655e404b73..ea91126c74 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -1108,32 +1108,6 @@ the input of another.")
using just two functions: melt and dcast (or acast).")
(license license:expat)))
-(define-public r-scales
- (package
- (name "r-scales")
- (version "1.0.0")
- (source
- (origin
- (method url-fetch)
- (uri (cran-uri "scales" version))
- (sha256
- (base32 "0353dkh3d7x78463c6ds80hcml59lrqwr8rlv82a8dnkxla4l7qc"))))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-labeling" ,r-labeling)
- ("r-munsell" ,r-munsell)
- ("r-rcolorbrewer" ,r-rcolorbrewer)
- ("r-rcpp" ,r-rcpp)
- ("r-r6" ,r-r6)
- ("r-viridislite" ,r-viridislite)))
- (home-page "https://github.com/hadley/scales")
- (synopsis "Scale functions for visualization")
- (description
- "This package provides graphical scales that map data to aesthetics, and
-provides methods for automatically determining breaks and labels for axes and
-legends.")
- (license license:expat)))
-
(define-public r-ggplot2
(package
(name "r-ggplot2")