summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-05-10 12:50:31 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-05-10 13:31:02 +0200
commitc9487dfadce4ba4cc03397871b4fb560f7e9653f (patch)
tree94fbf00a09cdb601e73035cdd842ce5c471805b7 /gnu
parent70debac5f1febe8a811de67d983bd4a8f3ec71f5 (diff)
downloadpatches-c9487dfadce4ba4cc03397871b4fb560f7e9653f.tar
patches-c9487dfadce4ba4cc03397871b4fb560f7e9653f.tar.gz
gnu: Add r-plot3d.
* gnu/packages/cran.scm (r-plot3d): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 564b6fd651..d00a4b3dd1 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -14314,3 +14314,25 @@ and model output.")
web-based tool for analyzing gene sets and returns any enrichment of common
annotated biological functions.")
(license license:gpl2+)))
+
+(define-public r-plot3d
+ (package
+ (name "r-plot3d")
+ (version "1.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "plot3D" version))
+ (sha256
+ (base32
+ "0chn70fqwyca8lbnjnpbcj08ni0dfbax2gjmzhk2c4w72c04mzpn"))))
+ (properties `((upstream-name . "plot3D")))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-misc3d" ,r-misc3d)))
+ (home-page "https://cran.r-project.org/web/packages/plot3D")
+ (synopsis "Plot multi-dimensional data")
+ (description
+ "This package provides functions for viewing 2D and 3D data, including
+perspective plots, slice plots, surface plots, scatter plots, etc. It
+includes data sets from oceanography.")
+ (license license:gpl3+)))