summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-05-10 12:48:31 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-05-10 13:31:02 +0200
commit5bea832f72b2205af57c716775552490f23b4914 (patch)
tree10bdc9b6b0fedbe5613b6cb3eea321748aa61aeb /gnu
parent4d06ef4b716f3023e6907c6abdc41c02d524a16b (diff)
downloadpatches-5bea832f72b2205af57c716775552490f23b4914.tar
patches-5bea832f72b2205af57c716775552490f23b4914.tar.gz
gnu: Add r-dalex.
* gnu/packages/cran.scm (r-dalex): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3c4ceca6c3..e91642abd1 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -14264,3 +14264,29 @@ engine (Salmon et al., 2011) as provided by the package @code{sitmo}.")
;; This package includes code under CC0 and Apache 2.0 or Expat, but as a
;; whole is distributed under the terms of the AGPL 3.
(license license:agpl3)))
+
+(define-public r-dalex
+ (package
+ (name "r-dalex")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "DALEX" version))
+ (sha256
+ (base32
+ "13l435l88r6wqaypxbf8jszc8wv5la1c3ahcxif2jcqlj4b1dks6"))))
+ (properties `((upstream-name . "DALEX")))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-ggplot2" ,r-ggplot2)))
+ (home-page "https://pbiecek.github.io/DALEX/")
+ (synopsis "Descriptive machine learning explanations")
+ (description
+ "Machine Learning models are widely used and have various applications in
+classification or regression. Models created with boosting, bagging, stacking
+or similar techniques are often used due to their high performance, but such
+black-box models usually lack interpretability. The DALEX package contains
+various explainers that help to understand the link between input variables
+and model output.")
+ ;; Any version of the GPL
+ (license license:gpl3+)))