summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-05-10 13:26:05 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-05-10 13:31:03 +0200
commit496b024fdecfaccb2200dc7e6aee798c1165d6cd (patch)
treece1c48d161eaeadb496b682b75a5222eafcec425 /gnu
parent5e0241db84afdabaa455634924a48528ed8ebbe3 (diff)
downloadpatches-496b024fdecfaccb2200dc7e6aee798c1165d6cd.tar
patches-496b024fdecfaccb2200dc7e6aee798c1165d6cd.tar.gz
gnu: Add r-rqc.
* gnu/packages/bioconductor.scm (r-rqc): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 62fd1132da..792fc68a7e 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -4507,3 +4507,44 @@ short genomic reads. It covers a complete workflow starting from raw sequence
reads, over creation of alignments and quality control plots, to the
quantification of genomic regions of interest.")
(license license:gpl2)))
+
+(define-public r-rqc
+ (package
+ (name "r-rqc")
+ (version "1.18.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "Rqc" version))
+ (sha256
+ (base32
+ "09kyn5nc2fqfdm3q07h0x2jyh24vsq5sxxm63ir1lvv250lmal4g"))))
+ (properties `((upstream-name . "Rqc")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biocgenerics" ,r-biocgenerics)
+ ("r-biocparallel" ,r-biocparallel)
+ ("r-biocstyle" ,r-biocstyle)
+ ("r-biostrings" ,r-biostrings)
+ ("r-biovizbase" ,r-biovizbase)
+ ("r-genomicalignments" ,r-genomicalignments)
+ ("r-genomicfiles" ,r-genomicfiles)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-iranges" ,r-iranges)
+ ("r-knitr" ,r-knitr)
+ ("r-markdown" ,r-markdown)
+ ("r-plyr" ,r-plyr)
+ ("r-rcpp" ,r-rcpp)
+ ("r-reshape2" ,r-reshape2)
+ ("r-rsamtools" ,r-rsamtools)
+ ("r-s4vectors" ,r-s4vectors)
+ ("r-shiny" ,r-shiny)
+ ("r-shortread" ,r-shortread)))
+ (home-page "https://github.com/labbcb/Rqc")
+ (synopsis "Quality control tool for high-throughput sequencing data")
+ (description
+ "Rqc is an optimized tool designed for quality control and assessment of
+high-throughput sequencing data. It performs parallel processing of entire
+files and produces a report which contains a set of high-resolution
+graphics.")
+ (license license:gpl2+)))