summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-01-12 18:12:16 -0500
committerMark H Weaver <mhw@netris.org>2015-01-12 18:37:16 -0500
commit65cd77db204b611009368da704e15add51fd9ba7 (patch)
treed740227e0a5a6b2e12da6bc901e019ea50d185ed /gnu
parentbdac3d4bf796402edf581a1f796d9ffc5d5c48f6 (diff)
downloadpatches-65cd77db204b611009368da704e15add51fd9ba7.tar
patches-65cd77db204b611009368da704e15add51fd9ba7.tar.gz
gnu: Add iw.
* gnu/packages/linux.scm (iw): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 0d49c54e61..12b754bae8 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -929,6 +929,32 @@ configuration and monitoring interfaces.")
;; 'nl-addr-add.c'), so the result is GPLv2-only.
(license gpl2)))
+(define-public iw
+ (package
+ (name "iw")
+ (version "3.17")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://www.kernel.org/pub/software/network/iw/iw-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "14zsapqhivk0ws5z21y1ys2c2czi05mzk7bl2yb7qxcfrnsjx9j8"))))
+ (build-system gnu-build-system)
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (inputs `(("libnl" ,libnl)))
+ (arguments
+ `(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ "CC=gcc")
+ #:phases (alist-delete 'configure %standard-phases)))
+ (home-page "http://wireless.kernel.org/en/users/Documentation/iw")
+ (synopsis "Tool for configuring wireless devices")
+ (description
+ "iw is a new nl80211 based CLI configuration utility for wireless
+devices. It replaces 'iwconfig', which is deprecated.")
+ (license isc)))
+
(define-public powertop
(package
(name "powertop")