summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-06-26 18:07:29 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-06-27 06:22:49 -0400
commitdc55b8b2341483a8b5d14a4335a609cc92eaceb2 (patch)
treee1c29cc9ba63e2e6fbcd23f0b6a44e8bbc4bb06b /gnu
parent8a6d273137a1485da2ba4c76c41e40c81f8f2f30 (diff)
downloadpatches-dc55b8b2341483a8b5d14a4335a609cc92eaceb2.tar
patches-dc55b8b2341483a8b5d14a4335a609cc92eaceb2.tar.gz
gnu: Enable libvpx support in ffmpeg.
* gnu/packages/video.scm (ffmpeg): Add libvpx input.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 8b63c59473..4509d81528 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -69,6 +69,7 @@
("opus" ,opus)
("libtheora" ,libtheora)
("libvorbis" ,libvorbis)
+ ("libvpx" ,libvpx)
("patchelf" ,patchelf)
("speex" ,speex)
("zlib", zlib)))
@@ -142,7 +143,6 @@
;; --enable-libvidstab enable video stabilization using vid.stab [no]
;; --enable-libvo-aacenc enable AAC encoding via libvo-aacenc [no]
;; --enable-libvo-amrwbenc enable AMR-WB encoding via libvo-amrwbenc [no]
-;; --enable-libvpx enable VP8 and VP9 de/encoding via libvpx [no]
;; --enable-libwavpack enable wavpack encoding via libwavpack [no]
;; --enable-libx264 enable H.264 encoding via x264 [no]
;; --enable-libxavs enable AVS encoding via xavs [no]
@@ -165,6 +165,7 @@
"--enable-libspeex"
"--enable-libtheora"
"--enable-libvorbis"
+ "--enable-libvpx"
;; drop special machine instructions not supported
;; on all instances of the target
,@(if (string-prefix? "x86_64"