summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndy Wingo <wingo@igalia.com>2017-09-19 21:19:08 +0200
committerAndy Wingo <wingo@igalia.com>2017-09-20 15:40:31 +0200
commit3511c78020fcf4a993b14bb2231f5a07e75701c0 (patch)
treee2b30c959254842806b2a985d6ae839f4ec4c937 /gnu
parentd831d49db97d59cf98c865ef9214c7a5b1c33a14 (diff)
downloadpatches-3511c78020fcf4a993b14bb2231f5a07e75701c0.tar
patches-3511c78020fcf4a993b14bb2231f5a07e75701c0.tar.gz
gnu: Add cheese.
* gnu/packages/gnome.scm (cheese): New public variable. Signed-off-by: Andy Wingo <wingo@igalia.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm62
1 files changed, 62 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 5b9c0f22f1..88b10435cb 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6779,3 +6779,65 @@ automatically and it can stream songs from online music services and charts.")
"A collection of GStreamer video filters and effects to be used in
photo-booth-like software, such as Cheese.")
(license license:gpl2+)))
+
+(define-public cheese
+ (package
+ (name "cheese")
+ (version "3.24.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/" name "-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "0wpks2lnr8va9wxgmj26dwmhlcb3vamhpxkqi8xaan6q25635l16"))))
+ (arguments
+ ;; Tests require GDK.
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'skip-gtk-update-icon-cache
+ (lambda _
+ ;; Don't create 'icon-theme.cache'
+ (substitute* "Makefile"
+ (("gtk-update-icon-cache") (which "true")))
+ #t))
+ (add-after 'install 'wrap-cheese
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH")))
+ (wrap-program (string-append out "/bin/cheese")
+ `("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path))))
+ #t)))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("glib:bin" ,glib "bin")
+ ("intltool" ,intltool)
+ ("itstool" ,itstool)
+ ("libxml2" ,libxml2)
+ ("pkg-config" ,pkg-config)
+ ("vala" ,vala)))
+ (propagated-inputs
+ `(("gnome-video-effects" ,gnome-video-effects)))
+ (inputs
+ `(("clutter" ,clutter)
+ ("clutter-gst" ,clutter-gst)
+ ("clutter-gtk" ,clutter-gtk)
+ ("gdk-pixbuf" ,gdk-pixbuf)
+ ("glib" ,glib)
+ ("gnome-desktop" ,gnome-desktop)
+ ("gobject-introspection" ,gobject-introspection)
+ ("gstreamer" ,gstreamer)
+ ("gst-plugins-base" ,gst-plugins-base)
+ ("gst-plugins-bad" ,gst-plugins-bad)
+ ("gtk+" ,gtk+)
+ ("libcanberra" ,libcanberra)
+ ("libx11" ,libx11)
+ ("libxtst" ,libxtst)))
+ (home-page "https://wiki.gnome.org/Apps/Cheese")
+ (synopsis "Webcam photo booth software for GNOME")
+ (description
+ "Cheese uses your webcam to take photos and videos. Cheese can also
+apply fancy special effects and lets you share the fun with others.")
+ (license license:gpl2+)))