summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-10-30 18:32:11 -0400
committerMarius Bakke <mbakke@fastmail.com>2016-11-08 16:14:04 +0000
commitfca4ff35594bbdff0a058fc4112b6ba523b7e1b0 (patch)
treea102ab9f0e75c1f911a3b54a71eb75473076f1d8 /gnu
parent667e777b4e4b7303b6f30a001fe2539b7207b65b (diff)
downloadpatches-fca4ff35594bbdff0a058fc4112b6ba523b7e1b0.tar
patches-fca4ff35594bbdff0a058fc4112b6ba523b7e1b0.tar.gz
gnu: Add python-pytest-2.9.2.
* gnu/packages/python.scm (python-pytest-2.9.2): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 5b5287e7c5..01eadcd237 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1668,6 +1668,31 @@ and many external plugins.")
(define-public python2-pytest
(package-with-python2 python-pytest))
+;; This package is used by Borg until we can upgrade all our Python packages to
+;; use a more recent pytest.
+(define-public python-pytest-2.9.2
+ (package
+ (inherit python-pytest)
+ (name "python-pytest")
+ (version "2.9.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest" version))
+ (sha256
+ (base32
+ "1n6igbc1b138wx1q5gca4pqw1j6nsyicfxds5n0b5989kaxqmh8j"))))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'disable-invalid-test
+ (lambda _
+ (substitute* "testing/test_argcomplete.py"
+ (("def test_remove_dir_prefix" line)
+ (string-append "@pytest.mark.skip"
+ "(reason=\"Assumes that /usr exists.\")\n "
+ line)))
+ #t)))))))
+
(define-public python-pytest-cov
(package
(name "python-pytest-cov")