summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2019-10-15 09:38:24 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2019-10-15 14:25:42 +0200
commit6830120e5822a4f3bb6927613dd624ef3d565980 (patch)
tree1a18cc812d6cab542f72fb77497a50b8c98a7048 /gnu
parentba42a6bfc413f0398a3f33a5580059896debd69f (diff)
downloadpatches-6830120e5822a4f3bb6927613dd624ef3d565980.tar
patches-6830120e5822a4f3bb6927613dd624ef3d565980.tar.gz
gnu: Add python-poyo.
* gnu/packages/python-xyz.scm (python-poyo): New public variable. Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f924aafc92..145de90d8e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1572,6 +1572,27 @@ existing ones.")
;; Tests don't work with python2.
#:tests? #f)))))
+(define-public python-poyo
+ (package
+ (name "python-poyo")
+ (version "0.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "poyo" version))
+ (sha256
+ (base32
+ "1pflivs6j22frz0v3dqxnvc8yb8fb52g11lqr88z0i8cg2m5csg2"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/hackebrot/poyo")
+ (synopsis "Lightweight YAML Parser for Python")
+ (description
+ "This package provides a lightweight YAML Parser for Python. It supports
+only a chosen subset of the YAML format that is required to parse cookiecutter
+user configuration files. It does not have support for serializing into YAML
+and is not compatible with JSON.")
+ (license license:expat)))
+
(define-public scons
(package
(name "scons")