summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorGuillaume LE VAILLANT <glv@posteo.net>2019-06-14 19:27:49 +0200
committerLudovic Courtès <ludo@gnu.org>2019-06-26 15:59:58 +0200
commitf825e60590be9c8215d345f72031abeb855b1a85 (patch)
treebec8fe4b8d140715b1f400348aac3da68d87a207 /gnu
parent83817158b20d90a918e12ad3fae0d357dac4e083 (diff)
downloadpatches-f825e60590be9c8215d345f72031abeb855b1a85.tar
patches-f825e60590be9c8215d345f72031abeb855b1a85.tar.gz
gnu: Add python-bsddb3
* gnu/packages/python-xyz.scm (python-bsddb3): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cb3a695bca..c94af80e2c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -60,6 +60,7 @@
;;; Copyright © 2019 Brett Gilio <brettg@posteo.net>
;;; Copyright © 2019 Sam <smbaines8@gmail.com>
;;; Copyright © 2019 Jack Hill <jackhill@jackhill.us>
+;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -88,6 +89,7 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages crypto)
#:use-module (gnu packages databases)
+ #:use-module (gnu packages dbm)
#:use-module (gnu packages file)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages gcc)
@@ -15622,3 +15624,40 @@ by Igor Pavlov.")
(define-public python2-pylzma
(package-with-python2 python-pylzma))
+
+(define-public python-bsddb3
+ (package
+ (name "python-bsddb3")
+ (version "6.2.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "bsddb3" version))
+ (sha256
+ (base32
+ "019db2y6bfmiqbrgg9x9f6h72qjmqh05czdn2v5sy9bl0gs23mj2"))))
+ (build-system python-build-system)
+ (inputs
+ `(("bdb" ,bdb)))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'configure-locations
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "BERKELEYDB_DIR" (assoc-ref inputs "bdb"))
+ (setenv "YES_I_HAVE_THE_RIGHT_TO_USE_THIS_BERKELEY_DB_VERSION" "1")
+ #t))
+ (replace 'check
+ (lambda _
+ (invoke "python3" "test3.py" "-v"))))))
+ (home-page "https://www.jcea.es/programacion/pybsddb.htm")
+ (synopsis "Python bindings for Oracle Berkeley DB")
+ (description
+ "This module provides a nearly complete wrapping of the Oracle/Sleepycat
+C API for the Database Environment, Database, Cursor, Log Cursor, Sequence and
+Transaction objects, and each of these is exposed as a Python type in the
+bsddb3.db module. The database objects can use various access methods: btree,
+hash, recno, and queue. Complete support of Berkeley DB distributed
+transactions. Complete support for Berkeley DB Replication Manager.
+Complete support for Berkeley DB Base Replication. Support for RPC.")
+ (license license:bsd-3)))