summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2019-11-01 12:46:02 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-11-04 10:05:13 +0100
commitf02249b6bf7b0a42ab5bc198f8147d86c406b66f (patch)
tree19b1775bd16f187697a41b79aaac458fb4144e41 /gnu
parente5c447907c0649ea3f662e1c27a25d0113ec921f (diff)
downloadpatches-f02249b6bf7b0a42ab5bc198f8147d86c406b66f.tar
patches-f02249b6bf7b0a42ab5bc198f8147d86c406b66f.tar.gz
gnu: Add emacs-leaf
* gnu/packages/emacs-xyz: (emacs-leaf): New variable. Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index cfd4b8702b..d0d0fcf920 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -55,6 +55,7 @@
;;; Copyright © 2019 Jelle Licht <jlicht@fsfe.org>
;;; Copyright © 2019 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;; Copyright © 2019 Stephen Webber <montokapro@gmail.com>
+;;; Copyright © 2019 Leo Prikler <leo.prikler@student.tugraz.at>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8959,6 +8960,36 @@ configuration in your @file{.emacs} file in a way that is both
performance-oriented and tidy.")
(license license:gpl2+)))
+(define-public emacs-leaf
+ (package
+ (name "emacs-leaf")
+ (version "3.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/conao3/leaf.el.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1rgd59146wad92yc64las0qgx67k2ifgsw1vwhp40xvkd7kb0r6d"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/conao3/leaf.el")
+ (arguments
+ `(#:tests? #t
+ #:test-command '("emacs" "--batch"
+ "-l" "leaf-tests.el"
+ "-f" "cort-test-run")))
+ (synopsis
+ "Simplify your init.el configuration, extended use-package")
+ (description
+ "This package provides macros that allows you to declaratively configure
+settings typical of an Elisp package with various keywords. The syntax is
+similar, but not identical to use-package -- overall, leaf aims at a cleaner
+and more predictable implementation.")
+ (license license:agpl3+)))
+
(define-public emacs-strace-mode
(let* ((commit "6a69b4b06db6797af56f33eda5cb28af94e59f11")
(revision "1"))