summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2014-04-15 17:40:23 +0200
committerAndreas Enge <andreas@enge.fr>2014-04-15 17:40:23 +0200
commitdc8d69760960d6c1467d73658b306e31ccac3332 (patch)
tree0adb80ab900c255415a1eafc021365bd6c1e5ebd /gnu
parent7e1c735f0bcbbc846a236bd66de7649204d47ab4 (diff)
downloadpatches-dc8d69760960d6c1467d73658b306e31ccac3332.tar
patches-dc8d69760960d6c1467d73658b306e31ccac3332.tar.gz
gnu: Add qjson.
* gnu/packages/kde.scm (qjson): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde.scm28
1 files changed, 26 insertions, 2 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 2666e58a7a..bb2a7ec997 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -17,7 +17,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages kde)
- #:use-module ((guix licenses) #:select (bsd-2 lgpl2.1+))
+ #:use-module ((guix licenses) #:select (bsd-2 lgpl2.1 lgpl2.1+))
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system cmake)
@@ -78,3 +78,27 @@
(synopsis "Qt 4 multimedia API")
(description "KDE desktop environment")
(license lgpl2.1+)))
+
+(define-public qjson
+ (package
+ (name "qjson")
+ (version "0.8.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/flavio/qjson/archive/"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "163fspi0xc705irv79qw861fmh68pjyla9vx3kqiq6xrdhb9834j"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("qt" ,qt-4)))
+ (arguments
+ `(#:tests? #f)) ; no test target
+ (home-page "http://qjson.sourceforge.net/")
+ (synopsis "Qt-based library for handling JSON")
+ (description "QJson is a Qt-based library that maps JSON data to QVariant
+objects and vice versa. JSON arrays are mapped to QVariantList instances,
+while JSON objects are mapped to QVariantMap.")
+ (license lgpl2.1+)))
+