summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2015-07-22 17:38:08 +0200
committerFederico Beffa <beffa@fbengineering.ch>2015-08-01 12:37:13 +0200
commitd4dbf10eb16401f9a8cbdf8b239586ea18528461 (patch)
tree6c5ffd0128413fa50a3e1d57ad2323b334a13a7a /gnu
parent6544aba5fc43c5e8f3ce558d02354cdde9a68ce9 (diff)
downloadpatches-d4dbf10eb16401f9a8cbdf8b239586ea18528461.tar
patches-d4dbf10eb16401f9a8cbdf8b239586ea18528461.tar.gz
gnu: Add emacs-dash.
* gnu/packages/emacs.scm (emacs-dash): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index e264eae21f..815a25805c 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -909,3 +909,28 @@ e.g. ghostscript and stored in the file-system, but rather created on-demand
and stored in memory.")
(home-page "https://github.com/politza/pdf-tools")
(license license:gpl3+)))
+
+(define-public emacs-dash
+ (package
+ (name "emacs-dash")
+ (version "2.11.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/magnars/dash.el/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1piwcwilkxcbjxx832mhb7q3pz1fgwp203r581bpqcw6kd5x726q"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'check
+ (lambda _
+ (zero? (system* "./run-tests.sh")))))))
+ (home-page "https://github.com/magnars/dash.el")
+ (synopsis "Modern list library for Emacs")
+ (description "This package provides a modern list API library for Emacs.")
+ (license license:gpl3+)))