summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-15 12:22:25 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-16 01:00:47 +0200
commitb744862704241f2ceb5b64fabccf5bff2a8fd781 (patch)
tree3be5b27c6bffb2522d7f8943d930affa823f9b3a /gnu
parent16c92e9d38b9bef1ac4c776ed98bd41fcc5ff321 (diff)
downloadpatches-b744862704241f2ceb5b64fabccf5bff2a8fd781.tar
patches-b744862704241f2ceb5b64fabccf5bff2a8fd781.tar.gz
gnu: lm-sensors: Don't use unstable tarball.
* gnu/packages/linux.scm (lm-sensors)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 8ea2869a26..4390526f16 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2488,17 +2488,17 @@ country-specific regulations for the wireless spectrum.")
(package
(name "lm-sensors")
(version "3.5.0")
- (source (origin
- (method url-fetch)
- (uri (list (string-append
- "https://github.com/groeck/lm-sensors/archive/V"
- (string-join (string-split version #\.) "-")
- ".tar.gz")))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1q6p6i8mrzxw70hfjvq4mlahnx2ahvbmyxsa78dmin2c7bbc2wgn"))
- (patches (search-patches "lm-sensors-hwmon-attrs.patch"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/groeck/lm-sensors.git")
+ (commit (string-append "V" (string-join
+ (string-split version #\.) "-")))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1mdrnb9r01z1xfdm6dpkywvf9yy9a4yzb59paih9sijwmigv19fj"))
+ (patches (search-patches "lm-sensors-hwmon-attrs.patch"))))
(build-system gnu-build-system)
(inputs `(("rrdtool" ,rrdtool)
("perl" ,perl)