summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-28 18:22:15 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-28 18:23:23 +0100
commita793e88c5ed84f78fded2051649c06e1ac9a3efc (patch)
tree7246d636bb12f3195a1106d1f3e945c18a1de153 /gnu
parentce77562a9e8cf2280a87b5462c33affc06c98de6 (diff)
downloadpatches-a793e88c5ed84f78fded2051649c06e1ac9a3efc.tar
patches-a793e88c5ed84f78fded2051649c06e1ac9a3efc.tar.gz
gnu: Add r-annaffy.
* gnu/packages/bioconductor.scm (r-annaffy): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 26ebb0930b..4cc9887d33 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2923,3 +2923,39 @@ profiles (GO and KEGG) of gene and gene clusters.")
data in R and Bioconductor containers.")
;; Any version of the LGPL.
(license license:lgpl2.1+)))
+
+(define-public r-annaffy
+ (package
+ (name "r-annaffy")
+ (version "1.54.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "annaffy" version))
+ (sha256
+ (base32
+ "16c6allp4vlx0g3nffanrm0mkkf8s2n31dccw4bflnx2pr81bmd5"))))
+ (build-system r-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-reference-to-non-free-data
+ (lambda _
+ (substitute* "DESCRIPTION"
+ ((", KEGG.db") ""))
+ #t)))))
+ (propagated-inputs
+ `(("r-annotationdbi" ,r-annotationdbi)
+ ("r-biobase" ,r-biobase)
+ ("r-dbi" ,r-dbi)
+ ("r-go-db" ,r-go-db)))
+ (home-page "https://bioconductor.org/packages/annaffy/")
+ (synopsis "Annotation tools for Affymetrix biological metadata")
+ (description
+ "This package provides functions for handling data from Bioconductor
+Affymetrix annotation data packages. It produces compact HTML and text
+reports including experimental data and URL links to many online databases.
+It allows searching of biological metadata using various criteria.")
+ ;; Any version of the LGPL according to the DESCRIPTION file. A copy of
+ ;; the LGPL 2.1 is included.
+ (license license:lgpl2.1+)))