summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2017-12-09 22:39:00 -0500
committerLudovic Courtès <ludo@gnu.org>2017-12-11 17:14:35 +0100
commit9faa46ee48d12bf55355805a84a7c533f904a39d (patch)
treefd698ffd61bd3d296b13f2b7dec0c76fd77a4bc3 /gnu
parent397d7980b7947742a1a49fe635503a29b7634e24 (diff)
downloadpatches-9faa46ee48d12bf55355805a84a7c533f904a39d.tar
patches-9faa46ee48d12bf55355805a84a7c533f904a39d.tar.gz
gnu: Add emacs-csv-mode.
* gnu/packages/emacs.scm (emacs-csv-mode): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index f5048c3dec..d5142d7ac0 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -6330,6 +6330,28 @@ and shell-command prompts that are based on bash completion.")
let users kill or mark things easily.")
(license license:gpl3+)))
+(define-public emacs-csv-mode
+ (package
+ (name "emacs-csv-mode")
+ (version "1.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://elpa.gnu.org/packages/csv-mode-"
+ version ".el"))
+ (sha256
+ (base32
+ "0r4bip0w3h55i8h6sxh06czf294mrhavybz0zypzrjw91m1bi7z6"))))
+ (build-system emacs-build-system)
+ (home-page
+ "http://elpa.gnu.org/packages/csv-mode.html")
+ (synopsis
+ "Major mode for editing comma/char separated values")
+ (description
+ "This Emacs package implements CSV mode, a major mode for editing records
+in a generalized CSV (character-separated values) format.")
+ (license license:gpl3+)))
+
(define-public emacs-transmission
(package
(name "emacs-transmission")